Lesson Weekend

Composer

We're going to use Composer's installer for Windows. Occasionally (and more frequently for windows machines) there are configuration files that need to be modified in order for Composer to work correctly. If you have to make changes take it one step at a time, and feel free to ask your teacher for help.

First, download the installer and follow along. (You'll need to find the file php.exe from your MAMP installation, we recommend using PHP 5.6.13, instead of the newest PHP 7.0.0 for now. You should find the file at "C:\MAMP\bin\php\php[yourversionnumber]".)

Rename your php.ini-development to php.ini, also found at "C:\MAMP\bin\php\php[yourversionnumber]".

If you receive errors that extensions or the extension_dir cannot be found, make sure that in your php.ini, your extension_dir line is not commented out, and points to the right directory on your computer (commonly C:\MAMP\bin\php\ext or similar).

Before editing php.ini:

before-changing-ini

After changing php.ini:

after-changing-ini

If while installing you get an error regarding 'SSL certificate authority' uncomment the following line in php.ini:

after uncommenting line in ini

Once complete, use the terminal to verify installation with the command $ composer --version